<!DOCTYPE html>
<html class="no-js mh-two-sb" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta name="google-site-verification" content="PHM0mx-rAwmtKRCrs0gEcSaaucGGUcr-s10gGwMAPzA" />
<!-- Analytics Tracking Code start -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-1472193-15']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- Analytics Tracking Code end -->
<!-- Google Page Level Ads Code Start -->
<script data-ad-client="ca-pub-4823718395360608" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Google Page Level Ads Code end -->

<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://whodiedtoday.com/xmlrpc.php" />

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Larry Edgeworth 61-year-old NBC News Employee Is Dead</title>
<meta name="description" content="Larry Edgeworth died Thursday, March 20, after testing positive for the coronavirus, the company announced on Friday. He suffered from other health issue"/>
<meta name="robots" content="index, nofollow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Larry Edgeworth 61-year-old NBC News Employee Is Dead">
<meta property="og:description" content="Larry Edgeworth died Thursday, March 20, after testing positive for the coronavirus, the company announced on Friday. He suffered from other health issue">
<meta property="og:url" content="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/">
<meta property="og:site_name" content="Who Died Today">
<meta property="article:publisher" content="https://www.facebook.com/celebritywhodiedtoday/">
<meta property="article:author" content="https://www.facebook.com/cakafete">
<meta property="article:tag" content="Andy Lack">
<meta property="article:tag" content="audio technician">
<meta property="article:tag" content="chairman">
<meta property="article:tag" content="edgeworth">
<meta property="article:tag" content="gentle giant">
<meta property="article:tag" content="Instagram">
<meta property="article:tag" content="NBC News">
<meta property="article:tag" content="president">
<meta property="article:tag" content="Savannah Guthrie">
<meta property="article:tag" content="united states">
<meta property="article:section" content="Gone But Not Forgotten">
<meta property="article:published_time" content="2020-03-20T20:29:00-04:00">
<meta property="article:modified_time" content="2020-03-20T21:42:29-04:00">
<meta property="og:updated_time" content="2020-03-20T21:42:29-04:00">
<meta property="fb:app_id" content="0554622171538732">
<meta property="og:image" content="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg">
<meta property="og:image:secure_url" content="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg">
<meta property="og:image:width" content="1200">
<meta property="og:image:height" content="675">
<meta property="og:image:alt" content="Larry Edgeworth 61-year-old NBC News employee died Thursday March 20 from coronavirus">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Larry Edgeworth 61-year-old NBC News Employee Is Dead">
<meta name="twitter:description" content="Larry Edgeworth died Thursday, March 20, after testing positive for the coronavirus, the company announced on Friday. He suffered from other health issue">
<meta name="twitter:site" content="@cakafete">
<meta name="twitter:creator" content="@cakafete">
<meta name="twitter:image" content="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg">
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"BlogPosting","headline":"Larry Edgeworth 61-year-old NBC News Employee Is Dead","description":"Larry Edgeworth died Thursday, March 20, after testing positive for the coronavirus, the company announced on Friday. He suffered from other health issue","datePublished":"2020-03-20T20:29:00-04:00","dateModified":"2020-03-20T21:42:29-04:00","publisher":{"@type":"Organization","name":"whodied-admin","logo":{"@type":"ImageObject","url":"https:\/\/whodiedtoday.com\/wp-content\/uploads\/2019\/05\/cropped-Whodiedtodaylogo.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/whodiedtoday.com\/dead-at-61-is-larry-edgeworth-nbc-news-employee\/"},"author":{"@type":"Person","name":"whodied-admin"},"image":{"@type":"ImageObject","url":"https:\/\/whodiedtoday.com\/wp-content\/uploads\/2020\/03\/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg","width":1200,"height":675}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Who Died Today &raquo; Feed" href="https://whodiedtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Who Died Today &raquo; Comments Feed" href="https://whodiedtoday.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Who Died Today &raquo; Larry Edgeworth 61-year-old NBC News employee is dead Comments Feed" href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1472193-15';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-1472193-15', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whodiedtoday.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://whodiedtoday.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wpbloom-css'  href='https://whodiedtoday.com/wp-content/plugins/bloom/public/css/wpbloom-public.css?ver=1.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://whodiedtoday.com/wp-content/themes/mh-magazine/style.css?ver=3.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://whodiedtoday.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://whodiedtoday.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://whodiedtoday.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://whodiedtoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/whodiedtoday.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://whodiedtoday.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript' src='https://whodiedtoday.com/wp-content/plugins/bloom/public/js/wpbloom-public.js?ver=1.5.1'></script>
<script type='text/javascript' src='https://whodiedtoday.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.6'></script>
<link rel='https://api.w.org/' href='https://whodiedtoday.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://whodiedtoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://whodiedtoday.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://whodiedtoday.com/?p=5142' />
<link rel="alternate" type="application/json+oembed" href="https://whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whodiedtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&#038;format=xml" />
	<meta name="keywords" content="Andy Lack, audio technician, chairman, edgeworth, gentle giant, Instagram, NBC News, president, Savannah Guthrie, united states" />
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="https://whodiedtoday.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="amphtml" href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/amp/"><link rel="icon" href="https://whodiedtoday.com/wp-content/uploads/2016/08/cropped-Whodiedtodayicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://whodiedtoday.com/wp-content/uploads/2016/08/cropped-Whodiedtodayicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://whodiedtoday.com/wp-content/uploads/2016/08/cropped-Whodiedtodayicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://whodiedtoday.com/wp-content/uploads/2016/08/cropped-Whodiedtodayicon-270x270.png" />
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-5142 single-format-standard wp-custom-logo mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-4" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- cakafete -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="8078307907"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://whodiedtoday.com/" class="custom-logo-link" rel="home"><img width="750" height="250" src="https://whodiedtoday.com/wp-content/uploads/2019/05/cropped-Whodiedtodaylogo.png" class="custom-logo" alt="Who Died Today" srcset="https://whodiedtoday.com/wp-content/uploads/2019/05/cropped-Whodiedtodaylogo.png 750w, https://whodiedtoday.com/wp-content/uploads/2019/05/cropped-Whodiedtodaylogo-300x100.png 300w" sizes="(max-width: 750px) 100vw, 750px" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="text-23" class="mh-widget mh-header-2 widget_text">			<div class="textwidget"><p><a href="https://www.review-products.ca/"><img class="aligncenter size-full wp-image-3905" src="https://whodiedtoday.com/wp-content/uploads/2019/05/banner-review-products.png" alt="review-products.ca" width="728" height="90" data-sitemapexclude="true" /></a></p>
</div>
		</div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-mainmenu-container"><ul id="menu-mainmenu" class="menu"><li id="menu-item-860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-860"><a href="https://whodiedtoday.com/category/who-died-on-dominica/">Dominica</a></li>
<li id="menu-item-861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-861"><a href="https://whodiedtoday.com/category/laid-to-rest/">Laid To Rest</a></li>
<li id="menu-item-890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-890"><a href="https://whodiedtoday.com/category/who-important-died-today/">Who Important Died Today</a></li>
<li id="menu-item-859" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-859"><a href="https://whodiedtoday.com/category/those-who-have-left-us-2/">Those Who Have Left US</a></li>
<li id="menu-item-857" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-857"><a href="https://whodiedtoday.com/category/gone-but-not-forgotten/">Gone but not forgotten</a></li>
<li id="menu-item-856" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-856"><a href="https://whodiedtoday.com/category/celebrity-video/">Video</a></li>
<li id="menu-item-1311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1311"><a href="https://whodiedtoday.com/category/people-that-died-today-celebs-who-died-today/">celebs who died today</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/" title="Larry Edgeworth 61-year-old NBC News employee is dead">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 20, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Larry Edgeworth 61-year-old NBC News employee is dead						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Gone But Not Forgotten							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://whodiedtoday.com/mother-lost-3-children-to-covid-19-is-dead-at-73/" title="Dead on Wednesday is 73-year-old Grace Fuscos, mother of N.J. family that already lost 3rd member to coronavirus.">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 19, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Dead on Wednesday is 73-year-old Grace Fuscos, mother of N.J. family that already lost 3rd member to coronavirus.						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Hot Trending News Today							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://whodiedtoday.com/lyle-wesley-waggoner-dead-84/" title="Lyle Wesley Waggoner from the Carol Burnett Show dead at 84">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Lyle Wesley Waggoner from the Carol Burnett Show dead at 84						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Who Important Died Today							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://whodiedtoday.com/eduard-limonov-political-activist-dead-at-77/" title="Eduard Limonov a Russian Writer, Political Activist dead at 77">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 17, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Eduard Limonov a Russian Writer, Political Activist dead at 77						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Who Important Died Today							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://whodiedtoday.com/22-new-covid-19-cases-reported-in-ontario/" title="Canada officials say new COVID-19 cases are sweeping through Canada">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ March 14, 2020 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Canada officials say new COVID-19 cases are sweeping through Canada						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Hot Trending News Today							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://whodiedtoday.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://whodiedtoday.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://whodiedtoday.com/category/gone-but-not-forgotten/" itemprop="url"><span itemprop="title">Gone But Not Forgotten</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Larry Edgeworth 61-year-old NBC News employee is dead</nav>
<article id="post-5142" class="post-5142 post type-post status-publish format-standard has-post-thumbnail hentry category-gone-but-not-forgotten tag-andy-lack tag-audio-technician tag-chairman tag-edgeworth tag-gentle-giant tag-instagram tag-nbc-news tag-president tag-savannah-guthrie tag-united-states">
	<header class="entry-header clearfix"><h1 class="entry-title">Larry Edgeworth 61-year-old NBC News employee is dead</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/03/">March 20, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://whodiedtoday.com/author/whodied-admin/">whodied-admin</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://whodiedtoday.com/category/gone-but-not-forgotten/" rel="category tag">Gone But Not Forgotten</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/#respond" class="mh-comment-count-link" >0</a></span>
</div>
	</header>
	<div id="text-26" class="mh-widget mh-posts-1 widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- cakafete --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="8078307907"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div>	<div class="entry-content clearfix">
<figure class="entry-thumbnail">
<img src="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-678x381.jpg" alt="Larry Edgeworth 61-year-old NBC News employee died Thursday March 20 from coronavirus" title="Larry Edgeworth 61-year-old NBC News employee died Thursday March 20 from coronavirus" />
</figure>
<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&t=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead:&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&media=https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg&description=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Larry%20Edgeworth%2061-year-old%20NBC%20News%20employee%20is%20dead&amp;body=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>

<p><span data-preserver-spaces="true">Larry Edgeworth died Thursday, March 20, after testing positive for the&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.foxnews.com/us/california-strictest-coronavirus-measures-new-rules" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">coronavirus</span></a><span data-preserver-spaces="true">, the&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.nbcnews.com/news/us-news/nbc-news-employee-dies-after-testing-positive-coronavirus-n1164696" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">company announced on Friday</span></a><span data-preserver-spaces="true">. Larry Edgeworth, a longtime staffer, worked at NBC News&#8217; 30 Rockefeller Plaza headquarters in New York and regularly traveled the world alongside reporters. He was an audio technician at the company for 25 years, according to NBC.</span></p>



<p><span data-preserver-spaces="true">Edgeworth&#8217;s wife, Crystal, told NBC that he suffered from other health issues in addition to coronavirus. He tested positive for coronavirus earlier in the week.</span></p>



<p><span data-preserver-spaces="true">NBC News chairman Andy Lack broke the tragic news in an email to colleagues, according to the organization&#8217;s&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.nbcnews.com/news/us-news/nbc-news-employee-dies-after-testing-positive-coronavirus-n1164696" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">website</span></a><span data-preserver-spaces="true">. &#8220;As we have heard from medical professionals, those with underlying health concerns are sadly the most vulnerable,&#8221; Lack wrote Friday morning.</span></p>



<p><span data-preserver-spaces="true">Lack wrote, &#8220;Many of you were fortunate enough to work with Larry over the years, so you know that he was the guy you wanted by your side no matter where you were.&#8221;&nbsp;</span></p>



<p><span data-preserver-spaces="true">Stacy Brady, NBCUniversal&#8217;s executive vice president of field and production operations, &#8220;says Larry Edgeworth was known as the &#8216;gentle giant who would give you the shirt off his back,'&#8221; Lack added.</span></p>



<p><span data-preserver-spaces="true">Other NBC News employees remembered Edgeworth for his professional demeanor and affability in any circumstance.</span></p>



<p><span data-preserver-spaces="true">&#8220;Larry was a gentle bear of a man, the heart and soul of our extended NBC family,&#8221; Andrea Mitchell, NBC News&#8217; chief foreign affairs correspondent, said. &#8220;I was always cheered and reassured, knowing he was on the team in the field. He always had my back whether here in the U.S. or the most dangerous situations around the world.&#8221;</span></p>



<figure class="wp-block-image size-large" data-amp-noloading="true" data-amp-lightbox="true"><img title="Andy Lack" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1-1024x576.jpg" alt="Larry Edgeworth 61-year-old NBC News employee died Thursday March 20 from coronavirus" class="wp-image-5155" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1-1024x576.jpg 1024w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1-300x169.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1-768x432.jpg 768w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1-678x381.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-1.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p><span data-preserver-spaces="true">In a&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.instagram.com/p/B99VGadHP-Y/" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">tribute on Instagram</span></a><span data-preserver-spaces="true">, &#8220;TODAY&#8221; co-anchor Savannah Guthrie said her &#8220;heart breaks&#8221; after learning Edgeworth died after getting COVID-19, the disease caused by the coronavirus.</span></p>



<p><span data-preserver-spaces="true">&#8220;I adored Larry,&#8221; she wrote. &#8220;We traveled together for two straight months on a campaign in 2008, and he was always the warmest, most professional, most loving. All hours of the day and night, no matter how hungry or tired or stressed we were &#8211; he was always a joy.&#8221;</span></p>



<p><span data-preserver-spaces="true">&#8220;Larry, dear, I will miss you,&#8221; she added.</span></p>



<h2><span data-preserver-spaces="true">His wife and two sons survive Larry Edgeworth.</span></h2>



<p><span data-preserver-spaces="true">Lack, in his email, NBC employees pointed they are doing everything that they can to support his family during the tough times.</span></p>



<p><span data-preserver-spaces="true">At least two other NBC News employees have tested positive for the coronavirus in recent days, prompting network officials to require most staffers at offices and bureaus across the country to work from home.</span></p>



<p><span data-preserver-spaces="true">After an&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.today.com/health/today-show-staff-member-tests-positive-coronavirus-t176033" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">employee of the 3rd hour of &#8220;TODAY&#8221; tested positive</span></a><span data-preserver-spaces="true">, hosts Craig Melvin and Al Roker began broadcasting from home as a precaution. Guthrie also began&nbsp;</span><a class="_e75a791d-denali-editor-page-rtfLink" href="https://www.today.com/news/savannah-guthrie-anchors-today-show-home-coronavirus-precautionary-reasons-t176205" target="_blank" rel="noopener noreferrer nofollow"><span data-preserver-spaces="true">co-anchoring from home</span></a><span data-preserver-spaces="true">.</span></p>



<p><span data-preserver-spaces="true">Other NBC workers who came into contact with the employee were all advised to self-isolate.</span></p>



<p><span data-preserver-spaces="true">&#8220;We are fully supporting our colleague, who is experiencing mild symptoms and receiving medical care,&#8221; NBC News President Noah Oppenheim said in a statement Monday. He added, &#8220;I know you join me in sending our very best for a quick recovery.&#8221;&nbsp;</span></p>



<p><span data-preserver-spaces="true">On Thursday night, Oppenheim said a Nightly News staffer based at 30 Rockefeller Plaza also tested positive. The employee has been working from home since March 13, when symptoms began.</span></p>



<h2>Coronavirus </h2>



<p>There are 18,170 confirmed coronavirus cases in the United States, and 241 people have died of the virus, according to CNN Health&#8217;s tally of U.S. cases that are detected and tested in the United States through U.S. public health systems. The total includes cases from all 50 states, the District of Columbia, and other U.S. territories, as well as all repatriated cases. <b>Coronavirus deaths top 10,000 globally</b>. </p>



<p>Coronavirus Symptoms (COVID-19) </p>



<p>Reported illnesses have ranged from people with mild symptoms to people being severely ill and dying. </p>



<p>Symptoms can include: </p>



<ul><li>Fever </li><li>Cough</li><li>Shortness of breath </li></ul>



<p><a class="rank-math-link" href="https://whodiedtoday.com">Top</a></p>
<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&t=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead:&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-linkedin" href="#" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&source=', 'linkedinShare', 'width=626,height=436'); return false;" title="Share on LinkedIn">
		<span class="mh-share-button"><i class="fa fa-linkedin"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F&media=https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus.jpg&description=Larry+Edgeworth+61-year-old+NBC+News+employee+is+dead', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Larry%20Edgeworth%2061-year-old%20NBC%20News%20employee%20is%20dead&amp;body=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
	<a class="mh-print" href="javascript:window.print()" title="Print this article">
		<span class="mh-share-button"><i class="fa fa-print"></i></span>
	</a>
</div></div>
	</div><div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://whodiedtoday.com/tag/andy-lack/" rel="tag">Andy Lack</a></li><li><a href="https://whodiedtoday.com/tag/audio-technician/" rel="tag">audio technician</a></li><li><a href="https://whodiedtoday.com/tag/chairman/" rel="tag">chairman</a></li><li><a href="https://whodiedtoday.com/tag/edgeworth/" rel="tag">edgeworth</a></li><li><a href="https://whodiedtoday.com/tag/gentle-giant/" rel="tag">gentle giant</a></li><li><a href="https://whodiedtoday.com/tag/instagram/" rel="tag">Instagram</a></li><li><a href="https://whodiedtoday.com/tag/nbc-news/" rel="tag">NBC News</a></li><li><a href="https://whodiedtoday.com/tag/president/" rel="tag">president</a></li><li><a href="https://whodiedtoday.com/tag/savannah-guthrie/" rel="tag">Savannah Guthrie</a></li><li><a href="https://whodiedtoday.com/tag/united-states/" rel="tag">united states</a></li></ul></div><div id="text-27" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><div id="amzn-assoc-ad-3e9cfe05-5685-4083-8933-bc64b0d4ce13"></div>
<p><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&#038;adInstanceId=3e9cfe05-5685-4083-8933-bc64b0d4ce13"></script></p>
</div>
		</div></article><nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://whodiedtoday.com/mother-lost-3-children-to-covid-19-is-dead-at-73/" rel="prev"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Grace Fuscos, mother" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Larry Edgeworth 61-year-old NBC News employee is dead 1"><span>Previous</span><p>Dead on Wednesday is 73-year-old Grace Fuscos, mother of N.J. family that already lost 3rd member to coronavirus.</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-3749 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://whodiedtoday.com/democrat-john-dingell-died-at-92/" title="92-Year-Old Michigan Democrat John Dingell Jr. has Died"><img width="326" height="184" src="https://whodiedtoday.com/wp-content/uploads/2019/02/crowley-john-dingell-career-1955-2013-longest-serving.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="John Dingell, longest serving member of US congress" srcset="https://whodiedtoday.com/wp-content/uploads/2019/02/crowley-john-dingell-career-1955-2013-longest-serving.jpg 980w, https://whodiedtoday.com/wp-content/uploads/2019/02/crowley-john-dingell-career-1955-2013-longest-serving-300x169.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2019/02/crowley-john-dingell-career-1955-2013-longest-serving-768x433.jpg 768w, https://whodiedtoday.com/wp-content/uploads/2019/02/crowley-john-dingell-career-1955-2013-longest-serving-107x60.jpg 107w" sizes="(max-width: 326px) 100vw, 326px" title="92-Year-Old Michigan Democrat John Dingell Jr. has Died 2">		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Who Important Died Today			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://whodiedtoday.com/democrat-john-dingell-died-at-92/" title="92-Year-Old Michigan Democrat John Dingell Jr. has Died" rel="bookmark">
			92-Year-Old Michigan Democrat John Dingell Jr. has Died		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2019/02/">February 8, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://whodiedtoday.com/author/whodied-admin/">whodied-admin</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://whodiedtoday.com/category/who-important-died-today/" rel="category tag">Who Important Died Today</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on 92-Year-Old Michigan Democrat John Dingell Jr. has Died</span></span></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The 92-Year-Old Michigan Democrat Michigan Democrat John Dingell Jr. was the longest-serving member of the United States Congress in history. He helped write most of the nation&#8217;s major environmental and energy laws. Dingel died Thursday, <a class="mh-excerpt-more" href="https://whodiedtoday.com/democrat-john-dingell-died-at-92/" title="92-Year-Old Michigan Democrat John Dingell Jr. has Died">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-4364 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://whodiedtoday.com/hussain-muhammad-ershad-dead-at-89/" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89"><img width="326" height="245" src="https://whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-326x245.png" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="Hussain Muhammad Ershad died at 89" srcset="https://whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-326x245.png 326w, https://whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-678x509.png 678w, https://whodiedtoday.com/wp-content/uploads/2019/07/Hussain-Muhammad-Ershad-80x60.png 80w" sizes="(max-width: 326px) 100vw, 326px" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89 3">		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Recently Died			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://whodiedtoday.com/hussain-muhammad-ershad-dead-at-89/" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89" rel="bookmark">
			Hussain Muhammad Ershad former Bangladesh army ruler dead at 89		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2019/07/">July 14, 2019</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://whodiedtoday.com/author/whodied-admin/">whodied-admin</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://whodiedtoday.com/category/recently-died/" rel="category tag">Recently Died</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Hussain Muhammad Ershad former Bangladesh army ruler dead at 89</span></span></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The former Bangladesh President and military ruler Hussain Muhammad Ershad have died at aged 89 following age-related health complications, an aide has said. Ershad died in hospital after being on life support for ten days. <a class="mh-excerpt-more" href="https://whodiedtoday.com/hussain-muhammad-ershad-dead-at-89/" title="Hussain Muhammad Ershad former Bangladesh army ruler dead at 89">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-149 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://whodiedtoday.com/doc-head-charles-dies-suddenly/" title="DOC head Charles dies suddenly"><img width="120" height="144" src="https://whodiedtoday.com/wp-content/uploads/2012/03/John_Charles.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="John_Charles" title="DOC head Charles dies suddenly 4">		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Those Who Have Left US			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://whodiedtoday.com/doc-head-charles-dies-suddenly/" title="DOC head Charles dies suddenly" rel="bookmark">
			DOC head Charles dies suddenly		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2012/03/">March 28, 2012</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://whodiedtoday.com/author/admin/">Administrator</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://whodiedtoday.com/category/those-who-have-left-us-2/" rel="category tag">Those Who Have Left US</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on DOC head Charles dies suddenly</span></span></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>ROSEAU, Dominica,&nbsp; CMC – President of the Dominica Olympic Committee, John Charles died Sunday, after collapsing suddenly. Charles, who owned several businesses in Roseau including the Charles Drug Store, was rushed to the Princess Margaret <a class="mh-excerpt-more" href="https://whodiedtoday.com/doc-head-charles-dies-suddenly/" title="DOC head Charles dies suddenly">[&#8230;]</a></p>
</div>	</div>
</article></div>
</div>
</section>
<div id="comments" class="mh-comments-wrap">
			<h4 class="mh-widget-title mh-comment-form-title">
				<span class="mh-widget-title-inner">
					Be the first to comment				</span>
			</h4>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dead-at-61-is-larry-edgeworth-nbc-news-employee/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=dead-at-61-is-larry-edgeworth-nbc-news-employee#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://whodiedtoday.com/wp-login.php?redirect_to=https%3A%2F%2Fwhodiedtoday.com%2Fdead-at-61-is-larry-edgeworth-nbc-news-employee%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="text-22" class="mh-widget widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- cakafete --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="8078307907"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div><div id="mh_magazine_facebook_page-2" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Follow on Facebook</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/celebritywhodiedtoday" data-width="300" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="mh_magazine_authors-2" class="mh-widget mh_magazine_authors"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Authors</span></h4>			<ul class="mh-user-widget mh-authors-widget clearfix">						<li class="mh-user-item clearfix">
															<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/author/whodied-admin/" title="Articles by whodied-admin">
										<img alt='' src='https://secure.gravatar.com/avatar/52f43473e452b98a2c861be7905df976?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/52f43473e452b98a2c861be7905df976?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' />									</a>
								</figure>
														<div class="mh-user-meta">
								<a class="mh-user-author-name" href="https://whodiedtoday.com/author/whodied-admin/" title="Articles by whodied-admin">
									whodied-admin								</a>
								<p class="mh-user-data">
									published 526 articles								</p>
							</div>
						</li>						<li class="mh-user-item clearfix">
															<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/author/admin/" title="Articles by Administrator">
										<img alt='' src='https://secure.gravatar.com/avatar/f58c42fed8c563fabe052df8c662aba2?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f58c42fed8c563fabe052df8c662aba2?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' />									</a>
								</figure>
														<div class="mh-user-meta">
								<a class="mh-user-author-name" href="https://whodiedtoday.com/author/admin/" title="Articles by Administrator">
									Administrator								</a>
								<p class="mh-user-data">
									published 114 articles								</p>
							</div>
						</li>			</ul></div><div id="mh_magazine_nip-2" class="mh-widget mh_magazine_nip">			<ul class="mh-nip-widget clearfix">					<li class="mh-nip-item post-5142 post type-post status-publish format-standard has-post-thumbnail category-gone-but-not-forgotten tag-andy-lack tag-audio-technician tag-chairman tag-edgeworth tag-gentle-giant tag-instagram tag-nbc-news tag-president tag-savannah-guthrie tag-united-states">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/dead-at-61-is-larry-edgeworth-nbc-news-employee/" title="Larry Edgeworth 61-year-old NBC News employee is dead">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Larry Edgeworth 61-year-old NBC News employee died Thursday March 20 from coronavirus" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Larry-Edgeworth-61-year-old-NBC-News-employee-died-Thursday-March-20-from-coronavirus-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Larry Edgeworth 61-year-old NBC News employee is dead 5">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5126 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today category-whodiedtoday tag-carmine-fusco tag-centrastate-medical-center tag-fuscos tag-grace-fusco tag-john-brennan tag-little-ferry tag-new-jersey tag-rita-fusco-jackson tag-teacher">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/mother-lost-3-children-to-covid-19-is-dead-at-73/" title="Dead on Wednesday is 73-year-old Grace Fuscos, mother of N.J. family that already lost 3rd member to coronavirus.">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Grace Fuscos, mother" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Grace-Fuscos-mother-2020-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Dead on Wednesday is 73-year-old Grace Fuscos, mother of N.J. family that already lost 3rd member to coronavirus. 6">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5102 post type-post status-publish format-standard has-post-thumbnail category-who-important-died-today tag-actor tag-carter tag-cbs tag-general-motors-institute-of-technology tag-kansas tag-kansas-city tag-lil-abner tag-marie-isern tag-missouri tag-tim-conway tag-washington-university-in-st-louis tag-west-germany">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/lyle-wesley-waggoner-dead-84/" title="Lyle Wesley Waggoner from the Carol Burnett Show dead at 84">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Lyle-Wesley-Waggoner-dead-at-84-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Lyle Wesley Waggoner" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Lyle-Wesley-Waggoner-dead-at-84-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Lyle-Wesley-Waggoner-dead-at-84-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Lyle-Wesley-Waggoner-dead-at-84-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Lyle Wesley Waggoner from the Carol Burnett Show dead at 84 7">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5087 post type-post status-publish format-standard has-post-thumbnail category-who-important-died-today tag-actress tag-eduard-limonov tag-eduard-savenko tag-eto-ya tag-garry-kasparov tag-its-russian tag-moscow tag-natalya-medvedeva tag-national-bolshevik-party tag-president tag-rt tag-russia tag-russia-party tag-sarajevo tag-soviet-union tag-twitter tag-united-states tag-writer">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/eduard-limonov-political-activist-dead-at-77/" title="Eduard Limonov a Russian Writer, Political Activist dead at 77">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Russian-writer-Eduard-Limonov-dead-at-77-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Eduard Limonov a Russian Writer, Political Activist dead at 77" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Russian-writer-Eduard-Limonov-dead-at-77-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Russian-writer-Eduard-Limonov-dead-at-77-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Russian-writer-Eduard-Limonov-dead-at-77-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Eduard Limonov a Russian Writer, Political Activist dead at 77 8">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5061 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today tag-canada tag-curling-world-championship tag-dennis-king tag-edward-island tag-europe tag-immune-systems tag-king-and-health-minister tag-michelle-mcquigge tag-new-brunswick tag-prince-edward-island tag-prince-george tag-public-health-agency-of-canada tag-quebec tag-recent-travel tag-second-cup tag-toronto tag-world-curling-federation tag-world-health-organization">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/22-new-covid-19-cases-reported-in-ontario/" title="Canada officials say new COVID-19 cases are sweeping through Canada">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/COVID-19-cases-are-sweeping-through-Canada-pm-and-premire-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="COVID-19 cases are sweeping through Canada" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/COVID-19-cases-are-sweeping-through-Canada-pm-and-premire-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/COVID-19-cases-are-sweeping-through-Canada-pm-and-premire-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/COVID-19-cases-are-sweeping-through-Canada-pm-and-premire-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Canada officials say new COVID-19 cases are sweeping through Canada 9">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5054 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-absolute-radio tag-adam tag-bbc-radio tag-content-director tag-donovan tag-helen tag-jo-houlcroft tag-key-103 tag-manchester tag-motown tag-noddy-holder tag-pete-mitchel tag-ronnie-spector tag-the-radio tag-virgin-radio-uk tag-xfm">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/dead-at-61-is-pete-mitchel-virgin-radio-presenter/" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Dead at 61 is Pete Mitchel the Virgin Radio Presenter" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter 10">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5045 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today tag-aide tag-brazil tag-cardiovascular-disease tag-china tag-chronic-respiratory-disease tag-communications-director tag-diabetes tag-dry-cough tag-fatigue tag-fbio-wajngarten tag-fever tag-florida tag-getty-images tag-headache tag-infection tag-instagram tag-jair-bolsonaro tag-mainstream-media tag-mild-illness tag-official tag-president tag-president-and-vice-president tag-press-secretary tag-rick-scott tag-severe-disease tag-shortness-of-breath tag-sore-throat tag-stephanie-grisham tag-the-who tag-trump tag-united-states tag-white-house tag-world-health-organization">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/brazilian-official-who-met-trump-test-positive-for-coronavirus/" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus &#8211; NPR">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 11" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-80x60.png 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-300x225.png 300w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-1024x767.png 1024w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-768x575.png 768w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-678x509.png 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8-326x245.png 326w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-8.png 1100w" sizes="(max-width: 80px) 100vw, 80px" title="Brazilian Official Who Met Trump Last Weekend Tests Positive For Coronavirus - NPR 12">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5034 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today tag-metoo tag-carol-kinsey-goman-carol-kinsey-goman tag-cornell-university-school-of-hotel-administration tag-hotel-administration tag-iliad tag-incomm-center-for-trade-show-research tag-leadership-coach tag-mayo-clinic tag-purchase-food-samples tag-rome tag-viruses">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/coronavirus-calls-for-social-distancing/" title="Coronavirus calls for social distancing and an end to shaking hands. Heres what were losing.">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-6-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Coronavirus calls for social distancing and an end to shaking hands. Heres what were losing. 13" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-6-80x60.png 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-6-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" title="Coronavirus calls for social distancing and an end to shaking hands. Heres what were losing. 14">							<div class="mh-nip-overlay"></div>
						</a>
					</li>					<li class="mh-nip-item post-5002 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today tag-nursing-home-the-nurse tag-centers-for-medicare-medicaid-services tag-chief-medical-officer tag-company-spokeswoman tag-curtis-luterman tag-denver tag-director-of-holly-heights-nursing-center tag-east-coast tag-executive-director tag-ganga tag-mike-pence tag-pat-herrick tag-seattle tag-the-thursday-news tag-various-government tag-vice">
						<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/a-nursing-home-spurs-precautions-across-us/" title="The nursing home at the center of coronavirus deaths spurs precautions across the U.S.">
							<img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-1-80x60.png" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="The nursing home at the center of coronavirus deaths spurs precautions across the U.S. 15" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-1-80x60.png 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-1-678x509.png 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/wp-header-logo-1-326x245.png 326w" sizes="(max-width: 80px) 100vw, 80px" title="The nursing home at the center of coronavirus deaths spurs precautions across the U.S. 16">							<div class="mh-nip-overlay"></div>
						</a>
					</li>			</ul></div><div id="mh_magazine_youtube-2" class="mh-widget mh_magazine_youtube">			<div class="mh-video-widget">
        		<div class="mh-video-container">
        			<iframe seamless width="1280" height="720" src="//www.youtube.com/embed/a2yI78E1GhI?wmode=opaque&amp;hd=1&amp;autoplay=0&amp;showinfo=0&amp;controls=0&amp;rel=0" allowfullscreen></iframe>
        		</div>
			</div></div><div id="mh_magazine_custom_posts-2" class="mh-widget mh_magazine_custom_posts">			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-3405 post type-post status-publish format-standard has-post-thumbnail category-who-important-died-today tag-albert-lexie tag-america tag-anaheim tag-california tag-caring-institute tag-childrens-hospital tag-childrens-hospital-of-pittsburgh tag-christopher-gessner tag-free-care-fund tag-major tag-major-league-baseball tag-mon-valley tag-monessen tag-monessen-high-school tag-pennsylvania tag-pittsburgh-foundation tag-president tag-the-pittsburgh-post-gazette tag-united-states tag-upmc-childrens-hospital-of-pittsburghs-free-care-fund">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/shoeshiner-albert-lexie-died/" title="Shoeshiner: Albert Lexie from Monessen died on October 16, 2018, at the age of 76."><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Albert Lexie was a shoeshiner from Monessen, Pennsylvania" srcset="https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309.jpg 600w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-300x225.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-560x419.jpg 560w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-260x195.jpg 260w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-160x120.jpg 160w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-386x290.jpg 386w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-290x218.jpg 290w, https://whodiedtoday.com/wp-content/uploads/2018/10/5EC01LFP-1539787309-193x145.jpg 193w" sizes="(max-width: 80px) 100vw, 80px" title="Shoeshiner: Albert Lexie from Monessen died on October 16, 2018, at the age of 76. 17">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/shoeshiner-albert-lexie-died/" title="Shoeshiner: Albert Lexie from Monessen died on October 16, 2018, at the age of 76.">
										Shoeshiner: Albert Lexie from Monessen died on October 16, 2018, at the age of 76.									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2018/10/">October 21, 2018</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Shoeshiner: Albert Lexie from Monessen died on October 16, 2018, at the age of 76.</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-2670 post type-post status-publish format-video has-post-thumbnail category-celebrity-video category-whodiedtoday tag-barbara-her tag-bob-dylan tag-bobby-vee tag-national-guard tag-pilot post_format-post-format-video">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/bobby-vee-1960s-pop-singer-dies-aged-73/" title="Bobby Vee: 1960s pop singer dies aged 73"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Bobby Vee: 1960s pop singer dies aged 73 18" srcset="https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5.jpg 640w, https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5-300x225.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5-153x115.jpg 153w, https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5-170x128.jpg 170w, https://whodiedtoday.com/wp-content/uploads/2016/10/sddefault-5-50x38.jpg 50w" sizes="(max-width: 80px) 100vw, 80px" title="Bobby Vee: 1960s pop singer dies aged 73 19">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/bobby-vee-1960s-pop-singer-dies-aged-73/" title="Bobby Vee: 1960s pop singer dies aged 73">
										Bobby Vee: 1960s pop singer dies aged 73									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2016/10/">October 24, 2016</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Bobby Vee: 1960s pop singer dies aged 73</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-467 post type-post status-publish format-standard has-post-thumbnail category-celebrityactor-who-died category-those-who-have-left-us-2 tag-dead tag-police tag-robin-williams tag-suicide">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/robin-williams-dead-in-apparent-suicide-police-reported/" title="Robin Williams Dead In Apparent Suicide Police Reported"><img width="65" height="60" src="https://whodiedtoday.com/wp-content/uploads/2014/08/robinwilliams.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Robin Williams Dead In Apparent Suicide Police Reported 20" srcset="https://whodiedtoday.com/wp-content/uploads/2014/08/robinwilliams.jpg 462w, https://whodiedtoday.com/wp-content/uploads/2014/08/robinwilliams-300x275.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2014/08/robinwilliams-260x239.jpg 260w, https://whodiedtoday.com/wp-content/uploads/2014/08/robinwilliams-160x147.jpg 160w" sizes="(max-width: 65px) 100vw, 65px" title="Robin Williams Dead In Apparent Suicide Police Reported 21">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/robin-williams-dead-in-apparent-suicide-police-reported/" title="Robin Williams Dead In Apparent Suicide Police Reported">
										Robin Williams Dead In Apparent Suicide Police Reported									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2014/08/">August 11, 2014</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://whodiedtoday.com/robin-williams-dead-in-apparent-suicide-police-reported/#comments" class="mh-comment-count-link" >2</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-886 post type-post status-publish format-standard has-post-thumbnail category-those-who-have-left-us-2 tag-director-wrtr tag-rt tag-the-oscar tag-thing-simon tag-york">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/legendary-director-mike-nichols-who-won-the-oscar-in-1968-for-the-classic-film-the-graduate-died-suddenly-on-wednesday-night/" title="Legendary director, Mike Nichols who won the Oscar in 1968 for the classic film &#8220;The Graduate&#8221; died suddenly on Wednesday night"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2014/11/mike-nichols-getty.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Mike Nichols died suddenly on Wednesday night" srcset="https://whodiedtoday.com/wp-content/uploads/2014/11/mike-nichols-getty.jpg 700w, https://whodiedtoday.com/wp-content/uploads/2014/11/mike-nichols-getty-300x222.jpg 300w, https://whodiedtoday.com/wp-content/uploads/2014/11/mike-nichols-getty-640x480.jpg 640w, https://whodiedtoday.com/wp-content/uploads/2014/11/mike-nichols-getty-624x463.jpg 624w" sizes="(max-width: 80px) 100vw, 80px" title="Legendary director, Mike Nichols who won the Oscar in 1968 for the classic film &quot;The Graduate&quot; died suddenly on Wednesday night 22">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/legendary-director-mike-nichols-who-won-the-oscar-in-1968-for-the-classic-film-the-graduate-died-suddenly-on-wednesday-night/" title="Legendary director, Mike Nichols who won the Oscar in 1968 for the classic film &#8220;The Graduate&#8221; died suddenly on Wednesday night">
										Legendary director, Mike Nichols who won the Oscar in 1968 for the classic film &#8220;The Graduate&#8221; died suddenly on Wednesday night									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2014/11/">November 19, 2014</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Legendary director, Mike Nichols who won the Oscar in 1968 for the classic film &#8220;The Graduate&#8221; died suddenly on Wednesday night</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-35 post type-post status-publish format-standard category-gone-but-not-forgotten category-those-who-have-left-us tag-american-television-series tag-in-south-korean-music tag-television-programs tag-television-series tag-today">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/he-left-us-so-young/" title="He left us so young"><img class="mh-image-placeholder" src="https://whodiedtoday.com/wp-content/themes/mh-magazine/images/placeholder-small.png" alt="No Picture" />									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/he-left-us-so-young/" title="He left us so young">
										He left us so young									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2007/07/">July 20, 2007</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on He left us so young</span></span></span>
</div>
							</div>
						</li>			</ul></div>	</aside>	</div>
    <aside class="mh-widget-col-1 mh-sidebar-2 mh-sidebar-wide" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
<div id="mh_magazine_facebook_page-4" class="mh-widget mh_magazine_facebook_page"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Our sister FB Page</span></h4><div class="mh-magazine-facebook-page-widget">
<div class="fb-page" data-href="https://www.facebook.com/amazonprimedealsdaily/" data-width="300" data-height="500" data-hide-cover="0" data-show-facepile="1" data-show-posts="0"></div>
</div>
</div><div id="custom_html-7" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Single post - 2 (weightloss.bobofindit.com) -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4823718395360608"
     data-ad-slot="6986591440"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="mh_magazine_custom_posts-9" class="mh-widget mh_magazine_custom_posts">			<ul class="mh-custom-posts-widget clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-large clearfix post-5054 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-absolute-radio tag-adam tag-bbc-radio tag-content-director tag-donovan tag-helen tag-jo-houlcroft tag-key-103 tag-manchester tag-motown tag-noddy-holder tag-pete-mitchel tag-ronnie-spector tag-the-radio tag-virgin-radio-uk tag-xfm">
							<div class="mh-custom-posts-large-inner clearfix">
																	<figure class="mh-custom-posts-thumb-xl">
										<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://whodiedtoday.com/dead-at-61-is-pete-mitchel-virgin-radio-presenter/" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter"><img width="326" height="245" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-326x245.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="Dead at 61 is Pete Mitchel the Virgin Radio Presenter" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-326x245.jpg 326w, https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Dead-at-61-is-Pete-Mitchel-the-Virgin-Radio-Presenter-80x60.jpg 80w" sizes="(max-width: 326px) 100vw, 326px" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter 23">										</a>
																			</figure>
																<div class="mh-custom-posts-content">
									<div class="mh-custom-posts-header">
										<h3 class="mh-custom-posts-xl-title">
											<a href="https://whodiedtoday.com/dead-at-61-is-pete-mitchel-virgin-radio-presenter/" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter">
												Dead at 61 is Pete Mitchel the Virgin Radio Presenter											</a>
										</h3>
										<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/03/">March 13, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://whodiedtoday.com/dead-at-61-is-pete-mitchel-virgin-radio-presenter/#respond" class="mh-comment-count-link" >0</a></span>
</div>
									</div>
									<div class="mh-excerpt">The British radio station &#8220;Virgin Radio&#8221; gave tribute to presenter Pete Mitchell on Friday afternoon following the news of his sudden death. The station told listeners in its 1 pm news bulletin that Pete had <a class="mh-excerpt-more" href="https://whodiedtoday.com/dead-at-61-is-pete-mitchel-virgin-radio-presenter/" title="Dead at 61 is Pete Mitchel the Virgin Radio Presenter">[...]</a></div>								</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4991 post type-post status-publish format-standard has-post-thumbnail category-hot-trending-news-today category-recently-died tag-china tag-coalition-party tag-disease tag-expediency-council tag-guardian-council tag-irans-administration tag-mahmoud-sadeghi tag-masih-daneshvari-hospital tag-representative">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/56-year-old-fatemeh-rahbar-iranian-mp-dead-from-coronavirus/" title="56-year-old Fatemeh Rahbar, Iranian MP is Dead from coronavirus"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/fatemeh-Rahbar-dead-at-56-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="56-year-old Fatemeh Rahbar, Iranian MP is Dead from coronavirus" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/fatemeh-Rahbar-dead-at-56-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/fatemeh-Rahbar-dead-at-56-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/fatemeh-Rahbar-dead-at-56-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="56-year-old Fatemeh Rahbar, Iranian MP is Dead from coronavirus 24">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/56-year-old-fatemeh-rahbar-iranian-mp-dead-from-coronavirus/" title="56-year-old Fatemeh Rahbar, Iranian MP is Dead from coronavirus">
										56-year-old Fatemeh Rahbar, Iranian MP is Dead from coronavirus									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/03/">March 7, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://whodiedtoday.com/56-year-old-fatemeh-rahbar-iranian-mp-dead-from-coronavirus/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4981 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-action-news-5 tag-america tag-atlanta tag-barbara-ann-battista tag-cable-news-network tag-cnn-center tag-newscaster tag-peabody-award tag-the-stations-50th-anniversary tag-wral-tv">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/bobbie-battista-former-cnn-news-anchor-dead-at-67/" title="Bobbie Battista the former CNN news Anchor dead at 67"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/03/Barbara-Ann-Bobbie-Battista-dead-at-63-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Bobbie Battista the former CNN news Anchor dead at 67" srcset="https://whodiedtoday.com/wp-content/uploads/2020/03/Barbara-Ann-Bobbie-Battista-dead-at-63-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/03/Barbara-Ann-Bobbie-Battista-dead-at-63-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/03/Barbara-Ann-Bobbie-Battista-dead-at-63-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Bobbie Battista the former CNN news Anchor dead at 67 25">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/bobbie-battista-former-cnn-news-anchor-dead-at-67/" title="Bobbie Battista the former CNN news Anchor dead at 67">
										Bobbie Battista the former CNN news Anchor dead at 67									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/03/">March 5, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Bobbie Battista the former CNN news Anchor dead at 67</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4942 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-advocate-christ-hospital tag-arlington-racecourse tag-dixie-crush tag-illinois tag-lindsey-renee-lagestee tag-lindsey-renee-lagestree tag-midwestern-university tag-parkway-bank-park tag-samantha-staley">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/25-year-old-lindsey-renee-lagestee-is-dead/" title="25-year-old Lindsey Renee Lagestee is dead"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/Lindsey-Renee-Lagestee-dead-at-25-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="25-year-old Lindsey Renee Lagestee is dead" srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/Lindsey-Renee-Lagestee-dead-at-25-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/Lindsey-Renee-Lagestee-dead-at-25-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/Lindsey-Renee-Lagestee-dead-at-25-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="25-year-old Lindsey Renee Lagestee is dead 26">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/25-year-old-lindsey-renee-lagestee-is-dead/" title="25-year-old Lindsey Renee Lagestee is dead">
										25-year-old Lindsey Renee Lagestee is dead									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 25, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on 25-year-old Lindsey Renee Lagestee is dead</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4933 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-america tag-john-glenn tag-langley-research-center tag-margot-lee-shetterly tag-national-advisory-committee-for-aeronautics tag-president tag-united-states-army tag-virginia tag-west-virginia-state-college tag-west-virginia-university">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/101-year-old-katherine-johnson-is-dead/" title="101-year-old Katherine Johnson an American mathematician is dead"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/101-year-old-Katherine-Johnson-an-American-mathematician-is-dead-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="101-year-old Katherine Johnson an American mathematician is dead" srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/101-year-old-Katherine-Johnson-an-American-mathematician-is-dead-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/101-year-old-Katherine-Johnson-an-American-mathematician-is-dead-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/101-year-old-Katherine-Johnson-an-American-mathematician-is-dead-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="101-year-old Katherine Johnson an American mathematician is dead 27">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/101-year-old-katherine-johnson-is-dead/" title="101-year-old Katherine Johnson an American mathematician is dead">
										101-year-old Katherine Johnson an American mathematician is dead									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 25, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on 101-year-old Katherine Johnson an American mathematician is dead</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4871 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-actor tag-boca-raton tag-chemotherapy tag-city-relief tag-hair-club-for-men tag-president tag-sy-sperling tag-talk-show-host tag-tokyo tag-vancouver">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/sy-sperling-founder-of-hair-club-for-men-dead-at-78/" title="Sy Sperling, founder of Hair Club for Men, dead at 78"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/Hair-Club-for-Men-a-hair-restoration-company-was-founded-by-Sy-Sperling-in-1976-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Hair Club for Men, a hair restoration company, was founded by Sperling in 1976." srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/Hair-Club-for-Men-a-hair-restoration-company-was-founded-by-Sy-Sperling-in-1976-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/Hair-Club-for-Men-a-hair-restoration-company-was-founded-by-Sy-Sperling-in-1976-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/Hair-Club-for-Men-a-hair-restoration-company-was-founded-by-Sy-Sperling-in-1976-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Sy Sperling, founder of Hair Club for Men, dead at 78 28">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/sy-sperling-founder-of-hair-club-for-men-dead-at-78/" title="Sy Sperling, founder of Hair Club for Men, dead at 78">
										Sy Sperling, founder of Hair Club for Men, dead at 78									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 21, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Sy Sperling, founder of Hair Club for Men, dead at 78</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4793 post type-post status-publish format-standard has-post-thumbnail category-celebrityactor-who-died category-recently-died tag-actress tag-attorney tag-elizabeth-mizener tag-kansas-city tag-kim-cattrall tag-kristin-davis tag-missouri tag-special-victims-unit tag-vanya">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/sex-and-the-city-actor-lynn-cohen-dead-at-86/" title="Lynn Cohen, the actor, best known as Magda in Sex and the City, dies aged 86"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/Lynn-Cohen-born-August-10-1933-is-an-American-actress-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Lynn Cohen, an actor, best known for playing the plainspoken housekeeper and nanny Magda in Sex and the City, has died. She was 86. Cohen died on Friday in New York City, said her manager, Josh Pultz. Additional details were not immediately available. A native of Kansas City, Missouri, Cohen had a long and diverse career as a stage, film and television performer. Her dozens of credits ranged from Nurse Jackie and The Marvelous Mrs. Maisel to the feature films Across the Universe and The Hunger Games: Catching Fire. In HBO&#039;s Sex and City, Cohen&#039;s character was used by attorney Miranda Hobbes, played by Cynthia Nixon. Magda was featured in the TV and movie versions of the popular show, which also starred Sarah Jessica Parker, Kristin Davis, and Kim Cattrall. Life and career - Lynn Cohen Lynn Cohen born on August 10, 1933, and died February 14, 2020. She was an American actress, best known for playing Magda in the HBO series Sex and the City and the 2008 film of the same name, as well as its 2010 sequel, and Mags in Cohen was born as Lynn Harriette Kay in Kansas City, Missouri, and was Jewish. She began her career appearing on the Off-Broadway productions as of the 1970s, receiving Drama League Award and Lucille Lortel Awards nominations. Cohen&#039;s first notable film role was in the 1993 comedy Manhattan Murder Mystery. From 1993 to 2006, she played Judge Elizabeth Mizener in the NBC drama series Law &amp; Order, appearing total in 12 episodes. She also guest-starred on NYPD Blue, Law &amp; Order: Special Victims Unit, Law &amp; Order: Criminal Intent, and had a recurring role on Damages. From 2000 to 2004, Cohen had a recurring role as Magda in the HBO comedy series, Sex, and the City. She reprised her role in the 2008 film of the same name, as well as its 2010 sequel. Cohen also appeared in the movies Munich (2005) playing Golda Meir, Vanya on 42nd Street, Synecdoche, New York, Eagle Eye, and The Hunger Games: Catching Fire. According to her manager Josh Pultz, Cohen died on February 14, 2020, in New York. The cause of death not yet known at the time of post this story." srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/Lynn-Cohen-born-August-10-1933-is-an-American-actress-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/Lynn-Cohen-born-August-10-1933-is-an-American-actress-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/Lynn-Cohen-born-August-10-1933-is-an-American-actress-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Lynn Cohen, the actor, best known as Magda in Sex and the City, dies aged 86 29">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/sex-and-the-city-actor-lynn-cohen-dead-at-86/" title="Lynn Cohen, the actor, best known as Magda in Sex and the City, dies aged 86">
										Lynn Cohen, the actor, best known as Magda in Sex and the City, dies aged 86									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 16, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Lynn Cohen, the actor, best known as Magda in Sex and the City, dies aged 86</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4781 post type-post status-publish format-standard has-post-thumbnail category-recently-died category-who-important-died-today tag-caroline-flack tag-instagram tag-london-metropolitan tag-love-island tag-spokesperson tag-the-guardian tag-united-kingdom tag-valentines-day tag-yahoo">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/caroline-flack-dead-at-40/" title="Caroline Flack, Former &#8216;Love Island&#8217; Host, Dead at age 40"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/Caroline-Flack-Former-Love-Island-Host-Dead-at-40-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Caroline Flack Former Love Island&#039; Host, Dead at 40" srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/Caroline-Flack-Former-Love-Island-Host-Dead-at-40-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/Caroline-Flack-Former-Love-Island-Host-Dead-at-40-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/Caroline-Flack-Former-Love-Island-Host-Dead-at-40-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Caroline Flack, Former &#039;Love Island&#039; Host, Dead at age 40 30">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/caroline-flack-dead-at-40/" title="Caroline Flack, Former &#8216;Love Island&#8217; Host, Dead at age 40">
										Caroline Flack, Former &#8216;Love Island&#8217; Host, Dead at age 40									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 15, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Caroline Flack, Former &#8216;Love Island&#8217; Host, Dead at age 40</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4726 post type-post status-publish format-standard has-post-thumbnail category-celebrityactor-who-died category-recently-died tag-author tag-bryna tag-lana-turner tag-man tag-michael-douglas">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/103-year-old-kirk-douglas-hollywood-legend-died/" title="103-Year-Old stage and screen actor Kirk Douglas Hollywood legend is dead"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2020/02/kirt-Douglas-actor-dead-at-103-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="kirt Douglas actor dead at 103" srcset="https://whodiedtoday.com/wp-content/uploads/2020/02/kirt-Douglas-actor-dead-at-103-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2020/02/kirt-Douglas-actor-dead-at-103-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2020/02/kirt-Douglas-actor-dead-at-103-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="103-Year-Old stage and screen actor Kirk Douglas Hollywood legend is dead 31">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/103-year-old-kirk-douglas-hollywood-legend-died/" title="103-Year-Old stage and screen actor Kirk Douglas Hollywood legend is dead">
										103-Year-Old stage and screen actor Kirk Douglas Hollywood legend is dead									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2020/02/">February 6, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on 103-Year-Old stage and screen actor Kirk Douglas Hollywood legend is dead</span></span></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-4607 post type-post status-publish format-standard has-post-thumbnail category-celebrityactor-who-died category-recently-died">
															<figure class="mh-custom-posts-thumb">
									<a class="mh-thumb-icon mh-thumb-icon-small" href="https://whodiedtoday.com/chuy-bravo-of-tv-show-chelsea-lately-dead-at-63/" title="Chuy Bravo of TV Show Chelsea Lately Dead at 63"><img width="80" height="60" src="https://whodiedtoday.com/wp-content/uploads/2019/12/Chuy-Bravo-was-a-Mexican-American-actor-and-entertainer-1-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Chuy Bravo born &quot;Jesús Melgoza&quot; on December 7, 1956" srcset="https://whodiedtoday.com/wp-content/uploads/2019/12/Chuy-Bravo-was-a-Mexican-American-actor-and-entertainer-1-80x60.jpg 80w, https://whodiedtoday.com/wp-content/uploads/2019/12/Chuy-Bravo-was-a-Mexican-American-actor-and-entertainer-1-678x509.jpg 678w, https://whodiedtoday.com/wp-content/uploads/2019/12/Chuy-Bravo-was-a-Mexican-American-actor-and-entertainer-1-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" title="Chuy Bravo of TV Show Chelsea Lately Dead at 63 32">									</a>
								</figure>
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://whodiedtoday.com/chuy-bravo-of-tv-show-chelsea-lately-dead-at-63/" title="Chuy Bravo of TV Show Chelsea Lately Dead at 63">
										Chuy Bravo of TV Show Chelsea Lately Dead at 63									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://whodiedtoday.com/2019/12/">December 22, 2019</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Chuy Bravo of TV Show Chelsea Lately Dead at 63</span></span></span>
</div>
							</div>
						</li>			</ul></div></aside>
</div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="custom_html-5" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ur1&category=primemain&banner=1WK0VRNA75J95DFZRE02&f=ifr&linkID=ff1a8ad4fe0b7e5e1c6976bf0e3412a5&t=ecompare0e-20&tracking_id=ecompare0e-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="custom_html-6" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="//rcm-na.amazon-adsystem.com/e/cm?o=1&p=12&l=ez&f=ifr&linkID=599d107ec24e5450556ee8903ecf5ddb&t=ecompare0e-20&tracking_id=ecompare0e-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
</div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="mh_magazine_recent_comments-2" class="mh-footer-widget mh_magazine_recent_comments"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Comments</span></h6>			<ul class="mh-user-widget mh-recent-comments-widget clearfix">						<li class="mh-user-item clearfix">								<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/a-tribute-to-jim-marshall-who-died-today-aged-88-rip/#comment-186" title="joe ardolino">
										<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />									</a>
								</figure>							<div class="mh-user-meta">
								<span class="mh-recent-comments-author">
									joe ardolino on 								</span>
								<a class="mh-recent-comments-link" href="https://whodiedtoday.com/a-tribute-to-jim-marshall-who-died-today-aged-88-rip/#comment-186" title="joe ardolino | A Tribute to Jim Marshall who died today aged 88 RiP">
									A Tribute to Jim Marshall who died today aged 88 RiP								</a>
							</div>
						</li>						<li class="mh-user-item clearfix">								<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-229" title="phiAndpi">
										<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />									</a>
								</figure>							<div class="mh-user-meta">
								<span class="mh-recent-comments-author">
									phiAndpi on 								</span>
								<a class="mh-recent-comments-link" href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-229" title="phiAndpi | Tribute to Sir Patrick Moore who died today.">
									Tribute to Sir Patrick Moore who died today.								</a>
							</div>
						</li>						<li class="mh-user-item clearfix">								<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-221" title="Toy Pupanbai">
										<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />									</a>
								</figure>							<div class="mh-user-meta">
								<span class="mh-recent-comments-author">
									Toy Pupanbai on 								</span>
								<a class="mh-recent-comments-link" href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-221" title="Toy Pupanbai | Tribute to Sir Patrick Moore who died today.">
									Tribute to Sir Patrick Moore who died today.								</a>
							</div>
						</li>						<li class="mh-user-item clearfix">								<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-222" title="An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory">
										<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />									</a>
								</figure>							<div class="mh-user-meta">
								<span class="mh-recent-comments-author">
									An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory on 								</span>
								<a class="mh-recent-comments-link" href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-222" title="An artist theory on the physics of &#039;Time&#039; as a physical process. Quantum Atom Theory | Tribute to Sir Patrick Moore who died today.">
									Tribute to Sir Patrick Moore who died today.								</a>
							</div>
						</li>						<li class="mh-user-item clearfix">								<figure class="mh-user-avatar">
									<a href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-220" title="Toy Pupanbai">
										<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' />									</a>
								</figure>							<div class="mh-user-meta">
								<span class="mh-recent-comments-author">
									Toy Pupanbai on 								</span>
								<a class="mh-recent-comments-link" href="https://whodiedtoday.com/tribute-to-sir-patrick-moore-who-died-today/#comment-220" title="Toy Pupanbai | Tribute to Sir Patrick Moore who died today.">
									Tribute to Sir Patrick Moore who died today.								</a>
							</div>
						</li>			</ul></div></div>
</div>
</footer>
	<div class="mh-footer-nav-mobile"></div>
	<nav class="mh-navigation mh-footer-nav" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-4234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4234"><a href="https://whodiedtoday.com/us/">About us</a></li>
<li id="menu-item-4235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4235"><a href="https://whodiedtoday.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-4233"><a href="https://whodiedtoday.com/">Who Died Today</a></li>
<li id="menu-item-4236" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4236"><a href="https://whodiedtoday.com/terms-and-conditions/">Terms And Conditions</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			WHODIEDTODAY.COM - Copyright © 1996 - 2019. All Rights Reserved.		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <script type='text/javascript' src='https://whodiedtoday.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://whodiedtoday.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202012.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'75994832',post:'5142',tz:'-4',srv:'whodiedtoday.com'} ]);
	_stq.push([ 'clickTrackerInit', '75994832', '5142' ]);
</script>
<script src="https://videopal.me/js/vp_player.min.js?v=1.1.29" data-cfasync="false"></script>
<script>
var vpPlayer = new VpPlayer({
    embedId: "3XxSsQ3n6PrM"
});</script>
</body>
</html>
